FAQ Ich kann keine Versionsinfo bei Miranda-vi hochladen

Aus dem Miranda-IM.de Wiki

Wechseln zu: Navigation, Suche
Warning.png
Teilweise ist die Herkunft der auf Miranda-vi angegebenen Downloads fragwürdig. Bei nur kleineren Problemen empfiehlt es sich also die dort angegebene Stable-Version zu verwenden, bzw. dass zzt. verwendete Plugin weiter zu verwenden.

Für einen Fehler beim Upload kann es mehrere Gründe geben. Hier werden die häufigsten Ursachen und Lösungswege beschrieben:

Upload wird geblockt (Access Denied)[Bearbeiten]

Überprüfen des Plugin Manger

Sollte ein User eine neue Pluginversion als erster bei Miranda-vi hochgeladen haben, aber keinen funktionierenden Link dazu angegeben haben, haben die Moderatoren vom Miranda-vi die Möglichkeit, diesem User den Upload zu sperren; bei Miranda-vi wird dies als "Ban" bezeichnet. Dabei wird der Upload solange gesperrt, bis der User den Link nachgereicht hat oder ein Moderator ihn für den User einträgt.

So sollte der Plugin Manager aussehen

Zum Beheben gehen Sie wie folgt vor:

  • Öffnen Sie den Plugin Manager über Services → PLUGINS_MANAGER
  • Es erscheint eine neue Ansicht, in welcher die Plugins gelistet sind, welche Sie als erster bei Miranda-vi gemeldet haben. Sollte hier ein Eintrag vorhanden sein, tragen Sie den funktionierenden Link zu Ihrer Pluginversion ein und klicken Sie auf UNBAN. Das sollte es gewesen sein.

Probleme bei der Verwendung der Plugins VIUploader oder Crash Dumper[Bearbeiten]

Die Plugins VersionInfo Uploader (besser bekannt als "VIUploader") und Crash Dumper bieten die Möglichkeit an, die eigene Versionsinfo direkt auf den Miranda-vi Server hochzuladen ohne die Website aufrufen zu müssen. Leider treten dabei des öfteren Fehler auf, die unterschiedliche Gründe haben, bspw. eine veraltete Pluginversion oder Änderungen an der technischen Infrastruktur von Miranda-vi.

Sollte es beim Upload der Versionsinfo mit einem dieser Plugins dauerhaft Probleme geben, wird dringend empfohlen zunächst zu überprüfen, ob ein direkter Upload via Webinterface von Miranda-vi möglich ist. Ist dies der Fall, sollte überprüft werden, ob es eine neuere Version des jeweiligen Plugins gibt.

Important.png
Nutzen Sie immer die aktuellste Version der Plugins VIUploader oder Crash Dumper um sicherzustellen, dass diese mit Miranda-vi kompatibel sind!

Weiterreichende Probleme[Bearbeiten]

Sollten trotz aller hier beschriebenen Lösungswege Probleme auftreten, können Sie Sich auch direkt an das Team von Miranda-vi wenden. Dazu wurde ein eigener IRC-Channel eingerichtet:

Tip.png
IRC-Channel von Miranda-vi.org:

Server: irc://irc.freenode.net, Channel: #miranda-vi

Alternativ kann auch der Webchat genutzt werden (Java ist hierfür erforderlich!)